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Introduction 
If you have just a few minutes or want to know just the basics, this is the place to start. This guide is designed 
to show you how to capture images from your screen, add annotations or other edits, and then send that 
capture somewhere useful. 

If you want more information on a particular step, or just want to spend some time getting to know a feature in 
depth, check out the written and video tutorials on the Learning Center on the TechSmith website 
(http://www.techsmith.com/learn/snagit). 

 

  

http://www.techsmith.com/learn/snagit�
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Getting Started with 
Snagit 10 
To take a screen capture, click the large red Capture button, or press 
the default hotkey, the <Print Screen> key. By default, the selected 
profile is All-in-One.  

 

When using the All-in-One profile: 

 

 

 

 Click and drag to select a region. 

 
 Hover to select a window or region inside a window. (Hover over the title bar to capture the full window.) 

 
 To capture a scrolling window, click the orange arrow that points in the direction you wish to scroll 

(vertical, horizontal, or both). 

 

Your capture is sent to the Editor, which opens automatically to display your capture. 
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Customize Your Capture 
Changing Snagit settings allows you to capture exactly what you need. Save your settings for easy re-use in a 
profile, or try out some of the different default profiles. 

 

Input 
The input type is how Snagit determines what area of 
the screen to capture. There are lots of inputs to 
choose from, but the All-in-One input combines the 
three most popular (Region, Window, and Scrolling 
Window) into one input. 

 

Output 
This is what Snagit does with your capture after you 
take it. You can send it to your Clipboard, e-mail, an 
FTP server, automatically save it as a file on your 
computer, or upload it to Screencast.com. You can 
even send it straight to another program. By default, 
the capture is previewed in the Editor.  

Effects 
Snagit can automatically add effects to captures 
before they are sent to their output destination, or 
before they are previewed in the Editor. By setting 
an effect to be done automatically, you can skip the 
need to use the Editor entirely. 

 

Options 
 

Six global options exist for captures. These options aren’t available for all types of 
captures; unavailable options appear disabled. 

Capture Modes 
Snagit has four capture modes. 
The mode determines what is 
captured when you use Snagit.  

Image: An image of your 
screen. 
Text: The text displayed on the 
screen. 
Video: A video of your screen. 
Web: Images or other kinds of 
files from a Web site. 

To take captures of your screen, 
leave Snagit in Image mode 
(the default).  
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Save Settings as a Profile 
A profile is a saved selection of mode, input, output, effect, and option settings. 

Instead of configuring common capture settings over and over again, save them as a profile. Selecting that 
profile uses that combination of settings when you use the capture button or default hotkey. 

 

Once you build the capture you want, you can save those settings in a profile. Profiles appear in the area 
above the Profile Settings pane and give you quick access to stored setting configurations. To save your 
current settings as a new profile, click the Save as New Profile button. 

 

 The Save Profile button saves your current settings in the currently selected profile. This replaces the 
settings in the default profiles if one of those are selected. You probably want to create a new profile 
instead of making changes to an existing one. 
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Editor Overview 
The Editor is used to add text, callouts (like speech bubbles), edge effects, borders, combine multiple images, 
and more.  

 

The Ribbon 
This is where most of Snagit Editor’s commands are located. Each tab contains related functions. For 
instance, you’ll find all the drawing tools on the Draw tab of the ribbon. 

Canvas 
The canvas is the work area used to display and edit your capture. 

Open Captures Tray 
The Tray is where all open captures appear. It includes recent captures as well as any files you open with 
Snagit Editor. Select a thumbnail in the Tray to edit that image. 

The Search Pane and Library 
Snagit automatically stores all of your captures and opened and saved files in the Library. With the powerful 
searching and filtering power of the Search Pane, It’s easy to find the capture you’re looking for. 
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The Ribbon 
Most of Snagit Editor’s commands are located in the ribbon. The ribbon is a tabbed interface that groups 
together similar functions. Here’s a brief overview of where you can find what you’re looking for. 

Application Button 
Tasks like opening and saving files are located in the Application menu. This is also where you 
access Editor-wide settings and options. 

 

Get a Live Preview 

Not quite sure what an effect does, or perhaps which effect you want? The ribbon has a live preview to show 
you what your capture looks like with that effect applied. To view a live preview of an effect or style change, 
hover your mouse cursor over the desired button in the ribbon. If available, a live preview of the change 
shows on the capture on your canvas. 

Ribbon Tabs 
The following pages give a brief tour of the various tabs found in Snagit. This is only a quick overview; if you 
need a detailed explanation or need to find a specific function, check the in-product help file for more 
information on each tab. To access the help file, press <F1> or click the blue help button in the upper right 
corner of Snagit Editor. 

 

 If the ribbon tabs are in your way, you can hide them by double-clicking the name of the tab. Double-click 
again to show them again. 
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Draw 

 
The Draw tab contains Editor’s drawing and annotation tools. After selecting a drawing tool, select a style 
from the style gallery, or use the Outline, Fill, and Effects menus to create your own. 

Several other frequently used commands are here as well. The Copy, Cut, and Paste buttons are on the 
Draw tab, as well as a handy dropdown containing all the items on the Send tab. This is also where the Finish 
Profile button is located for sending edited captures to their output destinations. 

Image 

 
The Image tab contains tools that affect how the entire image appears. 

Crop, trim, and resizing tasks are all located in the Canvas group. Items in this group change the size, border, 
and orientation of the image. 

The Image Style group has a gallery of image effects that add borders, edge effects, or make changes to the 
perspective of the image. You can customize image effects using the Border, Effects, and Edges menus. 
Most image effects can be applied to a selection as well as the entire image. 

The Modify group contains tools that modify the entire image. These tools change the image’s color and 
opacity, or add effects like watermarks and magnification. Other options include color effects and filters. 

Hotspots 

 
The Hotspots tab contains the tools used to add hotspots such a hyperlinks and mouse-over pop-ups to 
captures. 

Captures with hotspots must be saved in a hotspot compatible format, such as SWF. 
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Tags 

 
The Tags tab contains information about your capture and allows you to add keywords and flags to your 
capture. The tags and keywords make it easy to sort and find captures in the Snagit Editor Library. 

Add Keywords to your capture for detailed tagging, or use the default colored Flags for easy visual tagging. 
Flags show in the Library, the Open Captures Tray, and search pane.  

Metadata (information about the capture and when and where was captured) is located in the Details group. 
This information includes the application captured from, as well as the website URL if the capture was of a 
browser window. This metadata can be searched and filtered using the search pane to locate specific 
captures (such as all the screenshots taken of Firefox windows, or all the screenshots of www.techsmith.com).  

View 

 
The View tab contains carious tools that change how you view images and windows. Use it to show gridlines 
between pixels, zoom or pan the canvas, or cascade multiple open windows. Links to the help file and the 
TechSmith.com Learning Center can also be found on the View tab. 

Send 

 
The Send tab contains various output destinations and output accessories. Outputs are different places 
Snagit can send your capture. 

Output accessories send your capture to specific program or web destinations. Output accessories can be 
downloaded from the TechSmith website. Destinations include popular blog services, productivity applications, 
and the Microsoft ® Office suite of applications. 



Getting Started Guide 

www.techsmith.com  10 

Canvas 
Basics of the Canvas 
The canvas is the work area used to display and edit your capture. Initially, 
your capture takes up the entire canvas. Moving the crop handles (small 
white squares around the outside of your capture) or adjusting the canvas 
size on the Image tab gives you extra space to work on or crops your 
capture by removing canvas. 

By default, the canvas color is transparent. This means any area where 
the canvas shows is transparent, or see-through, in your saved image (if 
your file format supports transparency). The canvas color can be changed 
on the Image tab in the Canvas group. 

Objects on the Canvas 
When drawing tools like arrows, stamps, or callouts are used, they create vector objects that float above the 
canvas. Vector objects are like sticky notes on a picture; they can be moved around without changing what's 
underneath. 

When a file is saved in an image format, all vector objects are flattened. To retain vector objects, save a copy 
of your image as a SNAG file, the Snagit file format. This format retains all vector object information as well as 
undo information. 

 When you save your image in a standard file format, vector objects are not flattened immediately in the 
Editor. Only after closing an image in the Editor or closing Editor itself is the image reloaded as a 
flattened file. This allows you to make adjustments to the image even after a save, but only if the image or 
Editor is not closed. 

Images can be vector objects as well. Drag a thumbnail of an image from the Open Captures Tray to the 
canvas to add that image as a vector object. Pasted images or selections also exist on the canvas as vector 
objects. 

Selection Tool 

The selection tool  (Draw tab > Drawing tools group) is used to select a portion of the capture on the 
canvas. Once a selection is made, you have several options. 

 Copy: Use the Copy button on the Draw tab or <CTRL> + C to copy the selection to the Clipboard. If 
pasted in Snagit Editor, the selection is pasted as a vector object on the canvas. 

 Cut: Use the Cut button the Draw tab or <CTRL> + X to cut the selection out of the canvas and move it to 
the Clipboard. If pasted in Snagit Editor, the selection is pasted as a vector object on the canvas. 

 Drag: Dragging a selection to a new location acts like a cut, removing the selection and moving it to a 
new location. Unlike using cut and paste, however, dragging a selection does not make a new vector 
object. Instead, the dragged selection becomes a part of the canvas after it is moved and deselected, 
meaning that it can no longer be edited. 

 Clone: Hold down <CTRL> while dragging the selected area to move a copy of that selection to a new 
area, leaving the original selection in place. Like dragging a selected area, this does not make a new 
vector object. Instead, the dragged and cloned selection becomes a part of the canvas after it is moved 
and deselected, meaning that it can no longer be edited. 

Zoom the Canvas 
 Zoom tool on the Draw 

tab > Drawing Tools 
group  

 Zoom slider in the 
lower right corner of the 
Editor window  

 Holding CTRL and 
move the mouse scroll 
wheel. 
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Open Captures Tray 
The Open Captures Tray displays thumbnails of currently open captures. The currently selected capture is 
displayed on the Editor’s canvas. 

  

Tray Overview 
 An orange star means the capture has unsaved changes. 

 
 For saved files, the file extension is displayed. Auto-saved images have no file type displayed. 

 
 Close a capture (removing it from the Tray) by clicking the close button that appears when hovering over 

the thumbnail. This closes the capture, but does not remove it from your Library. Re-open the capture by 
double-clicking it in the Library. Permanently delete a capture by right-clicking the thumbnail and selecting 
Delete.  

 

Tray Tips  
 Drag thumbnails from the Tray to the canvas to mix images together. 
 Hover over a thumbnail in the Tray for a larger preview, along with information about that capture.  

 

 Expand the Tray by clicking . Scroll to view all open images. 
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The Search Pane and Library 
Snagit Editor includes a Library of all your previous captures. This could get overwhelming, but thanks to the 
powerful search and tagging capabilities of the Library, you can easily find the capture you’re looking for. 

The Search Pane is the way to browse or search your Library. The captures 
displayed in the main Library window are filtered by your search results or the 
selected options in the Tags, Dates, or Folders tabs. 

To view the Library of your captures, click the Library button in the lower right 
corner of the Editor. 

 

Search box 
Use the search box to search file names, keywords, and any metadata that is taken with the capture. 
Metadata includes the program it was captured from, the web site address, and even the web site title. This is 
great if you know exactly what you want, or are looking across all your captures. 

Filters 
 Tags: Browse your Library by a particular tag. Snagit creates tags automatically based on metadata.  

 Recent captures: View captures based on date. View captures from the past month, or view weekly 
breakdowns.  

 Applications: View captures by the application they were captured from.  
 Web sites: View captures based on the top level domain (e.g. www.techsmith.com).  
 Keywords: View captures based on keywords entered on the Tags tab of the Editor.  
 Flags: View captures by the user-assigned flags (assigned from either the Tags tab or the bottom of 

the search pane). 
 Dates: Browse your captures by year, months, or even specific day. 
 Folders: Browse your file system for image files. This view functions in a similar way to the Windows File 

Explorer. 

Flags and Keywords 
Flags function as visual markers; add them to a capture to make it stick out in your Tray or in the Library view. 
Each flag shows as a small badge on top of image thumbnails. Snagit provides names for the various flags, 
but these are just suggestions. The multicolored flags can symbolize whatever you like; the important thing is 
that they stick out visually. 

Keywords are a bit more specific. They’re all user defined. Think of keywords as a way to add information to 
your captures that shows up in searches and the Tags panel of the search pane. Try labeling captures with 
the name of project or the contents of the screen. 

The important thing to remember about flags and keywords is that they help you find and view groups of 
related captures. If you need to organize your captures, think flags and keywords. 

 You must manage media files with keywords and flags assigned within Editor or you lose the keywords 
and flags. For example, to move files with keywords and/or flags from one folder to another, you must use 
the Folder tab within the Search Pane. If you use Windows Explorer or another method to move these 
files, all keywords and flags are permanently lost.   
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More Information 
For more information about using Snagit, check these resources. 

Documentation 
In-product documentation is located in the help file. Access the help file by pressing <F1> or clicking the blue 
help button in the upper right corner of Snagit or Snagit Editor. 

Training 
For free video and written training on how to use Snagit, check out the TechSmith.com Learning Center 
(http://www.techsmith.com/learn).  

Support 
For free technical support for Snagit and other TechSmith products, visit our Support Center 
(http://www.techsmith.com/support). 

http://www.techsmith.com/learn�
http://www.techsmith.com/support�
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