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Introduction
The TechSmith Deployment Tool is designed for Information Technology (IT) specialists or system

administrators responsible for installing Snagit throughout an organization. The tool enables the

administrator to customize and generate a Windows Installer Transform file (MST) and a BAT file.

To view or customize the individual registry settings for Snagit, see Snagit MSI Installation Guide.
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Download the Deployment Tool
1. Download the Snagit MSI file and the TechSmith Deployment Tool from

www.techsmith.com/enterprise-resources.html.

2. Verify that .NET 4.7.2 is installed. Refer to .NET Framework versions and dependencies for details.

3. Double-click the TechSmith_Deployment_Tool.exe to launch the program.

By default, the Deployment Tool generates theMST and BAT files into the same directory aswhere

the executable is launched.
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Welcome Screen

1. On theWelcome screen, click theOpen MSI Package button.

2. Select the Snagit.msi file. If you have not previously downloaded theMSI file, download the file here.

3. ClickOpen.

TheMSI file opens in the Deployment Tool and displays the available options for creating a customMST file.
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Customize a Snagit Deployment
Click through the tabs on the left side of the TechSmith Deployment tool to view the customoptions

available.

The following sections describe the options available on each screen:

l General Options

l Disable Snagit Settings

l Install FeaturesOptions

l TechSmith FuseOptions
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l User Data Path Options

l Add Components

l Snagit Registry File Options

l Uninstall Options

l TechSmith RelayOptions

l Install DisplayOptions

l Create TransformFile
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Import Settings Options

You can duplicate the settings used in a previously created MST file.

1. On the Import Settings tab, click theOpen MST File button.

2. Browse to select the transform file (.mst).

Importing a transform file will reset your current Deployment Tool settings.

3. Click theOpen button.

The Deployment Tool automatically selects the settings from the imported transform file.
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General Options

Registration Information
Enter a username (e.g. your company or organization name) and the software key. If you have trouble

locating your software key, see License and Software Key FAQ.

If you enter a software key, make sure to select the Disable online Snagit registration dialog option on the

Disable Snagit Settings screen in the TechSmith Deployment Tool.
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At launch, Snagit validates the software key on each computer over an internet connection. For

instructions on how to activate offline, visit our support article:

https://support.techsmith.com/hc/en-us/articles/360050288752-Snagit-2021-Offline-Activation-

Method

Installation Path
By default, Snagit is installed to the following location on a user’smachine:

%ProgramFiles%\TechSmith\Snagit 2021

To select a custom location, click the Browse button or enter a path to the desired directory.

Installation Options

l Create shortcuts on Desktop: Creates shortcuts for Snagit and Snagit Editor on the desktop.

l Run Snagit whenWindows starts: Starts Snagit and the CaptureWindow. Snagit Editor starts in the
background.

Advanced Options
Snagit performsoptimizationswhen it detects it is running in a virtualized environment. The performance

optimizations include:

l Crosshairs are simplified when selecting an area to capture.

l Shadow effect is removed

l Crosshair lines do not extend across the entire screen

l Animation around the selected area is removed
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l The unselected area is not grayed out after a selection ismade.

l When a large desktop is detected:

l Snagit limits visual changes across the entire desktop.

l Snagit limits unnecessary animations.

Snagit can auto-detect most environments or you can select to always apply these optimizations. Select one

of the following options:

l Auto-Detect: Apply the optimizationswhen it detects that Snagit is running on a virtual machine.

l Yes: Always apply the optimizations.

l No:Do not apply the optimizations.

It is recommended to set this option to Yeswhen using virtualization technologies.

Product Language
Select the language for Snagit:

l ENU - English

l DEU -German

l ESN - Spanish

l FRA - French

l JPN - Japanese

l PTB - Portuguese
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TechSmith Support
Allow users to securely upload diagnostic files to our TechSmith support staff using the TechSmith Support

Tool in Snagit Editor.

The Support Tool is only available in Snagit version 2019.0.1 and later.
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Disable Snagit Settings

Option Description
When Should I
Consider Disabling
It?

Automatic
Updates

Automatically check for updates for Snagit. If disabled, the user will
not receive any application prompts when new versions are available.

l As an
administrator,
you want to
maintain control
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Option Description
When Should I
Consider Disabling
It?

of application
updates across
the organization
and not allow
users to install
updates.

l If you want to
require individual
users or user
groups to be on
a specific version
of the
application.

l You do notwant
the TechSmith
Uploader Service
to install during
an update.

Online Snagit
Registration
Dialog

After installing, the Snagit Registration dialog appears which includes
options to register the software online and sign up for product
announcements, customer stories, and free tutorials.

l Prevents the
online
registration
dialog from
displaying for
users.

l Helps to prevent
user entered
errors when
registering the
software or
duplicating the
registration
information
online.

Image Capture
Image capture takes a snapshot of anything on your screen including
a region, window, scrolling window, or the entire screen.

l If you want to
disable image
capture
including image
capture presets
and options.
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Option Description
When Should I
Consider Disabling
It?

Video
Record, trim unwanted sections, and playback MPEG-4 or Animated
GIF videos in Snagit.

l If users are
running Snagit
on a computer
that does not
support video
system
requirements.

l To allow an
administrator to
control
resources
(CPU/GPU/Band
width) when
deploying in
virtualized
environments.

l If running
Windows Server
2008 or
Windows Server
2008 R2 to
remove the video
capture and
playback options
for users. Video
playback and
decoding is not
supported on
this OS.

Printer Capture
Snagit installs as a printer destination for programs with printing

capability.

l When deploying
in a server
environment (e.g.
Remote Desktop
Services).
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Option Description
When Should I
Consider Disabling
It?

The Printer Capture Option scans the document in a program and

opens the capture in Snagit Editor.

If you

disable

printer

capture,

make sure

to also

disable the

Snagit

Printer

option on

the Install

Features tab

of the

Deployment

Tool.

Online Help

The Snagit help file is located online and requires an internet

connection. The online help provides content to assist in getting

started in Snagit and to find answers to product questions. While

offline, users can browse the basic help PDF located in Snagit.

The online help topics are located

here: https://support.techsmith.com/hc/en-

us/sections/360009844492.

l If the website is
restricted in your
organization or if
users do not
have an internet
connection, you
can choose to
disable the online
help. Disabling
this option opens
the basic help
PDF whenever a
user accesses
help in Snagit.
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Option Description
When Should I
Consider Disabling
It?

If you

disable

online help,

we

recommend

providing

users access

to download

the full help

PDF located

here.

TechSmith
Account Sign-In

TechSmith Accounts store user-specific information such as license
keys, your user profile, and Screencast.com and TechSmith Relay
logins. See About TechSmith Accounts.

l Sign in is not
required for
users when a
single or multi-
user key is
entered in the
Deployment
Tool.

l Signing into a
TechSmith
account allows
users to share to
Screencast.com
and TechSmith
Relay.

l You may
consider
disabling this
option if you do
notwant to
require users to
have TechSmith
accounts in your
organization.

Share Manager
The Share Manager allows users to update, add, or remove share
destinations from Snagit. To access the Share Manager in Snagit
Editor, select Edit > Editor Preferences > Share tab.

l If you select to
redirect the
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Option Description
When Should I
Consider Disabling
It?

destinations to a
path other than
the default.

l If you do not
want to allow
users to update
the destinations.

Local Crash
Dump
Collection

Allow Snagit to write crash dumps to
C:\Users\username\AppData\Local\TechSmith\Snagit\CrashDumps\
for diagnostic purposes. If this is disabled, crash dumps are written to
a temporary file.

l When you need
to preserve drive
storage space.

Disable

anonymous

usage reporting

Send anonymous data on Snagit usage to help TechSmith improve

future versions. Learn more about TechSmith User Design Initiative

(TUDI).

To receive in-app notifications, such as help tips and TechSmith

promotions, you must enable anonymous usage reporting.

Snagit sends an initial message during installation for

licensemanagement and compliance purposes.

l When you must
follow internet
security
requirements
that restricts
users from
sending data to
TechSmith.

l Or, if you do not
want to
participate in the
feedback
program.
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Install Features Options

Snagit share desinations are add-ons to help users upload content to third-partywebsites and applications.

The destinations appear in the Share dropdown in Snagit Editor.
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Select which destinations are available to users. If you disable any of the options above, the destinationswill

not appear on the Share tab for the end user.

For example, if YouTube is restricted in your organization, you maywant to remove the destination in Snagit.

Option Description

Snagit Printer

Snagit installs as a printer destination for programs with printing capability.

The Snagit Printer option scans the current document in a program and
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Option Description

opens the capture in Snagit Editor.

Windows Explorer Menu Extension
Allows users to quickly send and convert images using Batch Export. To
access Batch Export in Snagit Editor, select File > Export.

Snagit Share Destinations

The destinations appear in the Share dropdown in Snagit Editor and allow

users to share their captures to popular applications.

MicrosoftWord Share Allows users to insert an image into a MicrosoftWord document.

Microsoft Excel Share Allows users to insert an image into a Microsoft Excel workbook.

Microsoft PowerPoint Share
Allows users to insert an image into a Microsoft PowerPoint presentation
slide.

Screencast Share
Allows users to upload an image or video onto Screencast.com for hosting.
Screencast.com provides a URL for quick sharing or an embed code for
adding the capture onto a website or blog.

Camtasia Share

Allows users to import an image or video into the TechSmith Camtasia media

bin.

You must have Camasia version 7.0 or later installed to share

captures using this output.

YouTube Share
Allows users to upload a video onto YouTube for video hosting. YouTube
provides a URL for quick sharing to your audience or an embed code for
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Option Description

embedding the capture on a website or blog.

Google Drive Share
Allows users to upload an image or video to Google Drive for image or video
hosting. Snagit sends the share link to the Clipboard.

Dropbox Share
Allows users to upload an image or video to Dropbox for image or video
hosting. Snagit sends the share link to the Clipboard.

OneNote Share Allows users to insert an image into a Microsoft OneNote notebook.

TechSmith Knowmia Share

Allows users to upload an image or video to TechSmith Knowmia. Snagit
sends the share link to the Clipboard.

Deselect this option if you are disabling installation of the
TechSmith Uploader Service under the TechSmith Knowmia
Options tab.

Slack Share
Allows users to upload an image or video to a Slack workspace. Snagit sends
the share link to the Clipboard.

Box Share
Allows users to upload an image or video to Box for image or video hosting.
Snagit sends the share link to the Clipboard.

Force installation of Microsoft share
destinations if Office is not installed
on the target system

Forces the installation of Microsoft Office share destinations when Snagit
does not detect Office installed on the PC. Recommended for customized or
cloud installations of Office.
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TechSmith Fuse Options

TechSmith Fuse is a mobile app that allows you to send images and videos fromyourmobile device directly to

Snagit. You can capture, collaborate, and access your content -wherever you are.

Fuse is available from the App Store or Google Play and supported onmobile devices running the following

operating systems:

l iOS version 11.4 and later (phones and tablets)

l Android version 4.0.3 and later
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Some security settings and wireless network environmentsmay not allow connectivity to a desktop.

Make sure to confirmport 8299 is open when working in a virtual environment.
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User Data Paths Options

You can change or customize the location for storing user data on the User Data Paths screen.

Automatically Stored Files
Snagit automatically saves all captures into the DataStore folder. The default location for this folder is:

%LOCALAPPDATA%\TechSmith\Snagit\DataStore.

To help prevent users from losing data and to limit users fromchanging the path, it is recommended to

disable the option in the Deployment Tool to Allow user to change the automatically stored files location.

This option for users is located in Snagit Editor, select Edit > Editor Preferences > Library tab > Library location.

Installed Outputs (Share Destinations)
The Snagit outputs (destinations) appear in the Share dropdown in Snagit Editor and allow users to share their

captures to popular destinations.
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The default location to store the installed outputs (destinations) is:

l For Snagit 2021: %LOCALAPPDATA%\TechSmith\Snagit\Outputs\21

l For Snagit 2020: %LOCALAPPDATA%\TechSmith\Snagit\Outputs\20

l For Snagit 2019: %LOCALAPPDATA%\TechSmith\Snagit\Outputs\19

l For Snagit 2013: %LOCALAPPDATA%\TechSmith\Snagit\Accessories

.

If you select a custom folder to store the installed accessories, consider the following items:

l For roaming profiles, you should use a location that is common and available to all users. Snagit cannot
load outputs (destinations) froma network drive location.

l If a user does not havewrite access to the folder, Snagit disables the ability for users to update or remove
outputs (destinations) from the Share Preferences in Snagit Editor.

Other User Settings
User settings such as quick styles, cached thumbnails, additions to the spelling dictionary, TUDI files, etc. are

stored by default in: %LOCALAPPDATA%\TechSmith\Snagit.
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Add Components
The components added are included in the Snagit installation.

Share Destinations
Share destinations are add-ons designed to allow users to upload content to third-partywebsites and

applications. The destinations appear in the Share dropdown in Snagit Editor.

Deployment Tool Guide | 27



The destinations selected on the Install Features screen are included in the installation. To include additional

destinations:

1. Download more destinations to includewith deployment from thiswebsite:
https://support.techsmith.com/hc/en-us/articles/115002022732.

2. On the Add Components screen, click the Add button.

3. Browse and select the desired .tscplugin file. Control-click to select multiple files.

4. ClickOpen.

Presets
Set up a preset to automatically remember your capture settings. Use presets to:

l Save commonly used capture settings.

l Eliminate the setup time before each capture.

l Quickly switch between capture types based on the task at hand.

l Reduce the editing required by automatically adding effects or selecting the share location.
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To deploy Snagit with additional presets, add the exported Snagit Preset files (.snagpresets) on the Add

Components screen.
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1. Export the Snagit Preset file (.snagpresets) in Snagit Editor.

2. On the Add Components screen, click the Add button.

3. Browse and select the desired .snagpresets file. Control-click to select multiple files.

4. ClickOpen.

Tool Themes
Themesprovide a set of branded Quick Styles for each tool in Snagit Editor.
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To deploy Snagit with additional themes, add the exported theme files (.snagtheme) on the Add Components

screen.

1. Export the theme file (.snagtheme) in Snagit Editor.

2. On the Add Components screen, click the Add button.

3. Browse and select the desired .snagtheme file. Control-click to select multiple files.

4. ClickOpen.
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Snagit Registry File Options

The registry file contains custom settingswithin the Snagit application such as presets, appearance settings,

and hotkeys.

Some of these customsettings are located in the following locations:

l In the CaptureWindow, select File >Capture Preferences.

l In Snagit Editor, select Edit > Editor Preferences.
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Stamps, Quick Styles, and options in the toolbar are not stored in the registry file and cannot be

deployed tomultiple users.

To deploy customSnagit settings tomultiple users:

1. Install Snagit.

2. Set up Snagit with the desired settings and customizations for your organization.

3. Close Snagit.

4. Run Command Prompt as an administrator.

5. Make sure Snagit is not running. To create the Snagit registry file on your desktop, enter the following
into the Command Prompt:

"C:\ProgramFiles\TechSmith\Snagit 2021\Snagit32.exe" /e %userprofile%\Desktop\Snagit.reg

6. In the TechSmith Deployment tool, click the Snagit Registry File tab and select Customize Snagit registry
settings by importing a Snagit.reg file.

7. Click the Browse button to select a Snagit.reg file produced in step 5.

The transform (MST) file generated from the Deployment Tool will use the settings from the registry as the

default settingswhen installing Snagit.
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Uninstall Options

Keep or Delete Files
When uninstalling Snagit, there are three options for users' current Snagit files (unsaved captures, flags, tags,

and capture information). If you plan to reinstall or upgrade Snagit for a user, we recommend selecting the

Keep Files option.

Select one of the following options on the Uninstall Options screen:

l Prompt userswith this dialog:When uninstalling Snagit, allow the user to select whether to keep or
delete their current Snagit files.
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l Keep files: Automatically keep the user’s fileswhen uninstalling Snagit. Users are not prompted with this
dialog.

l Delete files: Automatically deletes the user’s fileswhen uninstalling Snagit. Users are not prompted with
this dialog.

Uninstall Previous Versions
The UninstallerTool.exe is embedded in the TechSmith Deployment Tool. To download, see Download the

Deployment Tool.

You can uninstall previous versions using:

l Uninstaller in the Deployment Tool

l Uninstaller Tool Command Line

To uninstall previous versionswithout deploying a new version of Snagit, see this support article.

Uninstall Previous Versions using the Deployment Tool

1. Download the Snagit MSI file and the TechSmith Deployment Tool from
www.techsmith.com/enterprise-resources.html.

2. Double-click the TechSmith_Deployment_Tool.exe to launch the program.

3. On theWelcome screen, click theOpen MSI Package button.

4. Select the Snagit.msi file. If you have not previously downloaded theMSI file, download the file here.

5. ClickOpen.

6. On the Uninstall Options screen, select an uninstall option:

l Uninstall all previous versions

l Uninstall only: Uninstalls specific versions of Snagit. Enter the Snagit major version number.
Separate versions by a comma. Make sure to enter the 2 digit version number (e.g. 20 not 2020).

7. Select the other desired options in the Deployment Tool for installing the new version of Snagit.
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8. On the Create Transform screen, enter the file path and clickCreate Transform.

9. The tool is extracted to the Batch file location selected. Copy theMSI, MST, BAT and
UninstallerTool.exe files to a folder on the target machine.

You must copy the BAT and UninstallerTool.exe files to the same folder and update the file

paths in the BAT file tomatch the folder location.

10. Open a command prompt with elevated Admin privileges.

11. Run the batch file to uninstall previous versions of Snagit and then install the new version.

You cannot right-click the BAT file and select Run as administrator to elevate file privileges.

Uninstall Previous Version using Command Line
The Uninstaller tool can be run independently or as part of the Deployment Tool process. Make sure to run

the command prompt with elevated Admin privileges.

Flags and parameters:

-product <insert product_name>

-keep <insert comma-separated version list>

-remove <insert comma-separated version list>

Examples:

1. Remove all versions of Snagit:

UninstallerTool.exe -product snagit

2. Remove only versions 2019 and 2021 of Snagit:

UninstallerTool.exe -product snagit -remove 19, 21

3. Remove all versions of Snagit except 2019 and 2021:

UninstallerTool.exe -product snagit -keep 19, 21

The Uninstaller tool writes progress information to the standard output. Windows installer log files are

created for each version of Snagit that is uninstalled. Windows installer log files can be found in the following

locations:
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l MSI installer logs: Located in the same folder as the Uninstaller tool and are in the formof "Uninstall_
<version>_Log.txt"

l EXE installer logs: Located in "%localappdata%\temp" with a file name in the formof "Snagit_<version>_
SnagitInstaller_<platform>.log"

Deployment Tool Guide | 37



TechSmith Relay Options

The RelayOptions configures Snagit with a share destination to your specific TechSmith Relay instance. For

this configuration, you need to enter both the primary endpoint (server URL) and Team ID.

Select the Disable installing the TechSmith Uploader Service option to prevent the TechSmith Uploader

Service from installing during deployment. We also recommend deselecting the TechSmith RelayDestination

under the Install Features tab.
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You must also select Disable automatic updates under the Disable Snagit Settings tab to prevent the

Uploader from installing during an update.

The primary endpoint value is theweb address of your TechSmith Relay Server ending in rest.ashx. For

example, http://www.organziation.com/relay/rest.ashx.

Themethod for retreiving your Team ID dependson your implementation of TechSmith Relay.

l If you have TechSmith Relay (Self-Hosted), you can log in to the TechSmith Relaywebsite as an
administrator and find it on the Servers page.

l If you have TechSmith Relay (Hosted), you can locate the Team ID on the Download Recorders page.

1. Fromyour TechSmith Relay homepage, click the Create button and then click the Download
Recorders link.

2. On the Download Recorder page, right-click the Configure Snagit button and Copy the link
address.

3. Paste the link into a text editor and extract the unique Team ID.

It is not recommended to select the option to ignore server certificate warnings.
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Install Display Options

Select one of the following options:

l Quiet display: Installs Snagit silentlywith no setup interface displayed. May be run froma non-
administrator command prompt. It will not return the command prompt until Snagit has finished
installing.

l Passive display: Installs Snagit froman administrator command prompt. It returns the command prompt
immediately (non-blocking). Theminimal setup is displayed and Snagit notifies the user when the
installation is complete.
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Create Transform File

1. Select I have read and accept the End User License Agreement checkbox.

2. Click the Create Transformbutton to generate the following files based on the options selected within

the Deployment Tool:

l Transform file (MST)

l Batch Processing file (BAT)
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Additional Resources

Enterprise Resources
TechSmith Enterprise Resourceswebsite

Download other resources and guides to assist with Snagit enterprise installations.

Technical Support
We're here for you! Visit the Technical Support website to submit a ticket, find answers online, or contact an

expert.
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