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Enterprise Installation Overview
This guide is designed for system administrators who want to customize and deploy Snagit installations across

a network.

This guide shows you how to manually edit the MSI file to create a transform file with the customized settings

to install Snagit across multiple computers on a network.

For a basic enterprise installations, use the TechSmith Deployment Tool. The Deployment Tool can

be downloaded here.

The enterprise installation of Snagit includes the following steps:

1. Prepare for the enterprise installation.

2. Create a central installation directory.

3. Create the custom installation using one of the following methods:

l Customize using the TechSmith Deployment tool

Download the Snagit Deployment Tool Guide here to learn more about using the tool and

the customizations available.

l Customize with a third-party tool (Advanced)

l Customize by editing the registry settings (Optional)

4. Install Snagit in a managed installation across the organization (recommended) or with a manual
installation on each individual computer.
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Preparing for an Enterprise Installation
Before starting the Snagit enterprise installation across your organization, complete the following:

1. Create a central installation directory.

2. Customize the installation using the basic or advanced customizations.

Step 1: Create a Central Installation Directory
A central installation directory on a network share (e.g. \\machine\share\Snagit) is required for most software

deployment schemes, including SMS, group policy, and manual deployment.

Create a central installation directory on a public network share and set the appropriate permissions.

Some deployment tools, such as Active Directory Group Policy, require that the client's machine

account have read access to the file share, because the software may be installed before any user

logs onto the system.

Step 2: Customize the Installation
There are three methods for customizing the installation:

l Customize using the TechSmith Deployment Tool (Recommended) 

The TechSmith Deployment Tool is recommended for most installations. The Deployment Tool

and PDF guide are available for download here.

l Customize with a third-party tool (Advanced)

l Advanced Customization: Edit the Registry Settings (Advanced)

Customization with a Third-Party Tool (Advanced)
Snagit is a standard Windows Installer-based package. These packages can be customized using transform files

(MST).

This option is only recommended if you have previous experience editing an MST file and a tool
available to edit your MST files.
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The Property and Feature Tables
Properties are associated with values that the user can enter into text boxes such as the registration key or

checkboxes in the installer. In general, checkboxes are enabled when they are set to 1 and disabled when the

property does not exist.

The following can be customized in the Property table:

Property Description

INSTALLDIR The location Snagit is installed.

TSC_SOFTWARE_KEY The registered software key.

TSC_START_AUTO Run Snagit when Windows starts.

START_NOW Run Snagit when the installation finishes.

TSC_FUSE_ENABLE Enable or disable connecting TechSmith Fuse to Snagit.

TSC_FUSE_PORT
Change the port for connecting TechSmith Fuse to Snagit to share image or
video files from a mobile device into Snagit.

TSC_NO_DATA_STORE_MOVE Set to 1 to hide the option for users to move the data store location.

TSC_DATA_STORE_LOCATION Enter the path to save the automatically stored files.

TSC_APP_DATA_PATH Enter the path to store user preferences and user released data files.

TSC_VM_OVERRIDE

Snagit can optimize the performance and display when running Snagit on a VM

or Remote Desktop. The optimizations include:

l Disable: automatic display of the tutorials Remove the animation for the
selection border.

l Do not show the background when selecting an area to capture.

l Shortened crosshairs for selection.

Set VMOverride to one of the following values:

l None:
Does not perform any optimizations if running on a VM or Remote
Desktop.

This option is the same as selecting "No" for the Virtual Machine

Optimization option in the TechSmith Deployment Tool.
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l AutoDetect:
Auto detects if Snagit is running on a VM or Remote Desktop and performs
optimizations.

This option is the same as selecting "AutoDetect" for the Virtual

Machine Optimization option in the TechSmith Deployment

Tool.

l OtherVM:
Automatically performs the optimizations.

This option is the same as selecting "Yes" for the Virtual Machine

Optimization option in the TechSmith Deployment Tool.

TSC_ACCESSORY_INSTALL_
PATH

Enter a path for AccessoryInstallPath to set location to install the Snagit Outputs.

TSC_ALLOW_OUTPUT_
MANAGER

The Output Manager allows users to update, add, or remove outputs from Snagit.
To access the Output Manager in Snagit Editor, select Edit > Editor Preferences >
Share tab.

TSC_ALLOW_TUDI

Send anonymous data on Snagit usage to help TechSmith improve future

versions. Learn more about TechSmith User Design Initiative (TUDI). This option

must be enabled for users to receive in-app notifications.

l Show me help and TechSmith promotions:

l TSC_TUDI_OPTIN_VALUE=1

l Only show me help notifications:

l TSC_TUDI_OPTIN_VALUE=1

l TSC_INAPPNOTIFICATIONBANNERPREFERENCE=1

l Don't show me notifications:

l TSC_TUDI_OPTIN_VALUE=1

l TSC_INAPPNOTIFICATIONBANNERPREFERENCE=0

l Disable anonymous usage reporting:

l TSC_TUDI_OPTIN_VALUE=0

TSC_ALLOW_IDENTITY
TechSmith Accounts store user-specific information such as license keys, your
user profile, and Screencast.com and TechSmith Knowmia logins. See About
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TechSmith Accounts.

TSC_ALLOW_ONLINE_HELP

The Snagit help file is located online and requires an internet connection. The

online help provides content to assist in getting started in Snagit and to find

answers to product questions. While offline, users can browse the basic help PDF

located in Snagit.

The online help is located here:

https://www.techsmith.com/learn/tutorials/snagit

TSC_APP_LANGUAGE

Set Snagit to default to the specified language for new installations. Set to:

l ENU for English

l DEU for German

l ESP for Spanish

l FRA for French

l JPN for Japanese

l PTB for Portuguese

TSC_CRASH_DUMPS_ENABLED Enable or disable sending crash dumps to the 3rd party BackTrace service.

TSC_BYPASS_WEBVIEW2_
CHECK

Enable or disable using the Edge WebView2 for displaying informational tooltips.

TSC_HIDE_REGISTRATION_KEY

Prevents Snagit from displaying the registration key in the Help menu > About

Snagit > Support Information dialog.

This property will be available for Snagit versions 22.0.1 and later.

TSC_DISABLE_WEBCAM_ON_
BY_DEFAULT

Set to 1 to disable Snagit from turning on the webcam by default for Video

captures.

The following examples demonstrate the use of the Property table:

l To distribute a site-wide registration key, add the property TSC_SOFTWARE_KEY to the Property table
and enter the registration key.

At launch, Snagit validates the software key on each computer over an internet connection. For

instructions on how to activate offline, visit our support article on Snagit Offline Activation:

https://support.techsmith.com/hc/en-us/articles/360050288752
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l If you do not want Snagit to automatically start when Windows starts, delete the TSC_START_AUTO row
from the Property table.

You can enable or disable some of the Snagit features in the Feature table.

l The Feature column lists the features that the conditions act on.

l The Level column controls the action to take on a feature when the expression in the Condition column
evaluates to true, where 3 means "always install" and 0 means "never install".

Advanced Customization: Edit the Registry Settings
(Advanced)
You can customize Snagit's settings using a Snag.reg file if you want to customize the options beyond the ones

available in the installer. For example, configure preferences, the interface, and more.

If you do not require additional customization, skip to the Installation section.

The custom registry process includes the following:

1. Set up Snagit on a computer with the preferences and other desired options.

2. You can then optionally add entries to the REG file manually.

3. Export the REG file. The exported REG file is deployed with the MSI installation.

SnagitCapture.exe exports program configuration settings from a file named Snagit.reg in the same directory.

This file can contain any user customizations such as program preferences, hotkeys, automatic updates, etc.

Snagit automatically imports these settings the first time it is run by each user. After that, Snagit uses

the settings saved by the user.

There are three steps to configure and obtain the REG file that will be deployed with Snagit.

Step 1: Configure Snagit using the Snagit Interface
1. Make any desired changes in Snagit.

Presets, Quick Styles, and Themes are not stored in the registry. They can be deployed by using

the Deployment Tool using Snagit 13.1.0 or later.

2. In the Capture window, select File > Exit Snagit to close Snagit completely. It is important to exit Snagit
and Snagit Editor or your settings will not be saved properly. Make sure Snagit has not been minimized to
the Notifications area.
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3. Export the Snagit registry settings by opening a command prompt as an administrator. Navigate to where
Snagit is installed on your computer and run the following command: 

SnagitCapture.exe /e snagit.reg

Step 2: Manually Edit the REG File
The Snagit.reg file is compatible with the Regedit.exe program in Windows. It is not recommended to use a text

editor to edit the REG file.

Capture settings and other features in Snagit can be disabled by adding registry entries directly to the Snagit

registry. These changes are exported in step three for the distribution with SnagitCapture.exe.

1. Click the Windows Start button and type regedit.

2. Navigate to the following (default) path: HKEY_CURRENT_USER > Software > TechSmith > Snagit.

3. Add or modify entries as described in the examples below.

4. Exit RegEdit.

Examples
To disable image capture for each user, add these lines to the registry:

[HKEY_CURRENT_USER\Software\TechSmith\Snagit\22\]

"NoImageCaptureSupport"=dword:00000001

To disable both image and printer capture support, add these lines to the registry:

[HKEY_CURRENT_USER\Software\TechSmith\Snagit\22\]

"NoImageCaptureSupport"=dword:00000001

"NoPrinterCaptureSupport"=dword:00000001

The following list contains the features that can be disabled in the Snagit registry:

l To disable image capture:
Set NoImageCaptureSupport to dword: 00000001

l To disable video capture:
Set NoVideoCaptureSupport to dword: 00000001

l To disable printer capture:
Set NoPrinterCaptureSupport to dword: 00000001

l To disable prompting for Snagit Printer installation:
Set NoPrinterInstallationSupport to dword: 00000001
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l To disable automatic update prompts and checks for new versions:
Set NoAutoUpdateSupport to dword: 00000001

l To disable "Register Snagit" online dialog:
Set NoRegistrationDialogSupport to dword: 00000001

l To opt out of TechSmith's anonymous data collection:
Set TUDIOptedIn to dword:00000000

l To opt into TechSmith's anonymous data collection:
Set TUDIOptedIn to dword: 00000001

l Enter a path for AppDataPath to set the location to save the custom user settings, such as Quick Styles,
thumbnails, and accessories.

l Enter a path for DataStoreLocation to set the location to store the auto-saved captures and metadata.

l To hide the option for users to move their data store location:
Set DataStoreNoMove to dword: 0000001

l Set VMOverride to one of the following values:

l None
Does not perform any optimizations if running on a VM or Remote Desktop.

l AutoDetect
Auto detects if Snagit is running on a VM or Remote Desktop and performs optimizations.

l OtherVM
Automatically performs the optimizations. Optimizations include: Disable automatically displaying
the tutorials, remove the animation for the selection border, do not show the background during
selecting an area to capture, shortened crosshairs for selection.

l Enter a path for AccessoryInstallPath to set location to install the Snagit Outputs.

l To disable the in-product notifications, set TSC_IN_PRODUCT_NOTIFICATIONS_ALLOW=0

Step 3: Export the REG File
1. Click the Windows Start button and type "CMD" into the search field to open a command prompt.

2. Navigate to the folder where SnagitCapture.exe is installed. Typically it is located in C:\Program
Files\TechSmith\Snagit 2022\.

3. Export the REG file by running the following command:
SnagitCapture.exe /e c:\Users\Public\Snagit.reg
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Installation
You can complete the Snagit enterprise installation across your organization by using one of the following

procedures:

l A managed installation across the organization (recommended).

l Manual installations on each computer in the organization.

When upgrading Snagit to a newer version, a dialog prompts users to keep or delete their existing

Library files. If the user is not available to select an option, the installation fails.

As a workaround, complete a deployment-wide uninstall of the previous version before installing

a newer version of Snagit. During the silent uninstall, an administrator can specify via a

command line flag whether to keep or delete existing Library files.

l Use TSC_DATA_STORE=1 to bypass the prompt and remove the user's library.

l Use TSC_DATA_STORE=0 to bypass the prompt and keep the user's library.

Managed Installation Using Group Policy in Windows
2012 or 2016 Server
Using the Windows 2016 or 2012 Server's Group Policy manager, it is easy to deploy Snagit to everyone in your

organization.

The following describes one method for deploying Snagit. You can use your preferred method for deploying

software in your environment.

1. In the Administrative Tools, open Group Policy Management.

2. Select the Default Domain Policy. Right-click and select Edit.

3. In the User Configuration, expand Policies and then expand Software Settings.

4. Right-click Software Installation and select New > Package.

5. Enter the UNC path to the share. Enter the full UNC path to share, not a local drive. Or, browse to the
location through the network.

6. Select Assigned or Advanced for the deployment method.

7. Select Modifications tab > Add.
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8. Choose the appropriate MST files to transform the package and click OK.

When deploying, make sure accounts for the client computers have at least read access to

share.

9. If desired, move the Snag.reg file created earlier into the same directory as the installer. Make sure the file
is readable by the client's accounts.

The client's computer installs Snagit on the next user login.

Managed Installation Using Active Directory Group
Policy
Using the Active Directory Group Policy manager, it is easy to deploy Snagit to everyone in your organization.

The following describes one method for deploying Snagit. You can use your preferred method for deploying

software in your environment.

1. Run the Active Directory Users and Computers snap-in.

2. Right-click on the domain and select Properties.

3. On the Group Policy tab, select the default domain policy and click Edit.

4. Expand Software Settings under Computer Configuration.

5. Right-click Software Installation and select New Package.

6. Enter the UNC path to share. Enter the full UNC path to share, not a local drive. Or, browse to the location
through My Network Places.

7. Select Advanced published or assigned.

8. On the Modifications tab, click Add.

9. Choose the appropriate MST files to transform the package and click OK. Make sure that the accounts for
the clients' computers have at least read access to share.

10. If desired, add the Snagit.reg file created earlier into the same directory as the installer. Make sure that the
accounts for the clients' computers have at least read access to share.

The client's computer installs Snagit on the next user login.

Any errors are logged in the Event Viewer. A common reason for installation failure is an unreadable

package, transform, or Snagit.reg file. Make sure that the share and files are readable by the client's

computer.
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Distribute Snagit Manually
If you do not have a Windows server or another deployment mechanism, you can manually install using the

command line. This could be placed in a batch file or script.

1. Add the installer, the Snagit.reg file, and the transform into the same directory on the central file share.
The installer searches for a file named Snagit.reg in the same directory as the original MSI file and, if
present, automatically installs it into the main Snagit installation directory.

2. The package and customizations can now be installed manually on the client's computer using msiexec.

3. Any transforms (MST files) are applied by specifying the transform filenames in the property
TRANSFORMS on the msiexec command line. Multiple transform files are separated by semicolons.

4. To install Snagit without any user dialogs, applying a transform named "Setup_Snagit.mst," run the
following command:

msiexec /i \\machine\share\Snagit\Setup_Snagit.msi

TRANSFORMS="Setup_Snagit.mst" /qn
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