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All rights reserved

This manual, as well as the software described in it, is furnished under license andmay be used or copied only
in accordance with the terms of such license. The content of this manual is furnished for informational use
only, is subject to change without notice and should not be construed as a commitment by TechSmith Cor-
poration. TechSmith Corporation assumes no responsibility or liability for any errors or inaccuracies that may
appear in this manual.

Trademarks

All-in-One Capture, Camtasia, Camtasia Relay, Camtasia Studio, Coach's Eye, DubIt, EnSharpen, Enter-
priseWide, Expressshow, Jing, Morae, Rich Recording Technology (RRT), Screencast.com, ScreenChomp,
Show TheWorld, SmartFocus, Snagit, TechSmith, TechSmith Fuse, TSCC and UserVue are either
registeredmarks or marks of TechSmith Corporation in the U.S. and/or other countries. This list is not a com-
prehensive list of all TechSmith Corporationmarks. The absence of a name/mark or logo in this notice does
not constitute a waiver of any intellectual property rights that TechSmith Corporation has established in any of
its product, feature or service names/marks or logos. All other marks are the property of their respective own-
ers.
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Introduction
The TechSmith Deployment Tool is designed for Information Technology (IT) specialists or system admin-
istrators responsible for installing Snagit throughout an organization. The tool enables the administrator to cus-
tomize and generate aWindows Installer Transform file (MST) and a BAT file.

To view or customize the individual registry settings for Snagit, seeSnagit MSI Installation Guide.

http://www.techsmith.com/enterprise-resources.html
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Download the Deployment Tool
1. Download the Snagit MSI file and the TechSmith Deployment Tool: www.techsmith.com/enterprise-

resources.html.
2. Double-click TechSmith_Deployment_Tool.exe to launch the program.

Note: By default, the Deployment Tool generates theMST and BAT files into the same directory as
where the executable is launched.

Welcome Screen

1. On theWelcome screen, click the OpenMSI Package button.
2. Select the Snagit.msi file. If you have not previously downloaded theMSI file, download the file here.
3. Click Open.

TheMSI file opens in the Deployment Tool and displays the available options for creating a customMST file.

http://www.techsmith.com/enterprise-resources.html
http://www.techsmith.com/enterprise-resources.html
http://www.techsmith.com/enterprise-resources.html
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Customize a Snagit Deployment
Click through the tabs on the left side of the TechSmith Deployment tool to view the custom options available.

The following sections describe the options available on each screen:

General Options

Disable Snagit Settings

Install Features Options

TechSmith Fuse Options

User Data Path Options

Add Snagit Accessories Options

Snagit Registry File Options

Uninstall Options

Install Display Options

Create Transform File
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General Options

Registration Information

Enter a username (e.g. your company or organization name) and the software key. If you have trouble locating
your software key, seeCommon Trial Questions tutorial.

If you enter a software key, make sure to select the “Disable online Snagit registration dialog” option on the
Disable Snagit Settings screen in the TechSmith Deployment Tool.

Installation Path

By default, Snagit is installed to the following location on a user’s machine:

On 32-bit Windows: %programfiles%\TechSmith\Snagit<version>

On 64-bit Windows: %Program Files(x86)%\TechSmith\Snagit<version>

To select a custom location, click the Browse button or enter a path to the desired directory.

Installation Options

Create shortcuts on Desktop:Creates shortcuts for Snagit and Snagit Editor on the desktop.

Run Snagit when Windows starts:Starts Snagit and the CaptureWindow. Snagit Editor starts in the
background.

Advanced Options

Snagit performs optimizations when it detects it is running in a virtualized environment. The performance
optimizations include:

http://www.techsmith.com/tutorial-snagit-12-common-trial-questions.html
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Simplified appearance of the crosshairs when selecting an area to capture.

Removed the shadow effect

Do not extend the crosshair lines across the entire screen

Removed the animation around the selected area

After selecting the area, the unselected area is not grayed out.

Virtual machines usually have an application bar that covers the CaptureWindow in its default loc-
ation. The optimization changes the location of the CaptureWindow to the top-left of the screen.
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When a large desktop is detected:

Snagit limits visual changes across the entire desktop.

Snagit limits unnecessary animations.

Automatic Snagit in-context help is turned off. Users will not see the following animations or videos by
default:

The “Let me try” animation when a user takes their first capture.

The “Scrolling Capture” animation.

The “Video Edit” video after a user takes their first video capture. Users can view the video in
Snagit Editor by selecting Cut Video Tutorial from the Help dropdownmenu.

The “Manage Profiles” video the first time a user opens theManage Profiles dialog. Users can
view the video by selecting Help > Manage Profiles Tutorial in theManage Profiles dialog.

Snagit can auto-detect most environments or you can select to always apply these optimizations. Select one
of the following options:

Auto-Detect:Apply the optimizations when it detects that Snagit is running on a virtual machine.

Yes:Always apply the optimizations.

No:Do not apply the optimizations.

Note: It is recommended to set this option to Yes when using virtualization technologies.
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Disable Snagit Settings

Option Description When Should I Consider
Disabling It?

Automatic
Updates

Automatically check for updates for Snagit. If dis-
abled, the user will not receive any application
prompts when new versions are available.

As an administrator,
you want to maintain
control of application
updates across the
organization and not
allow users to install
updates.
If you want to require
individual users or
user groups to be on a
specific version of the
application.
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Option Description When Should I Consider
Disabling It?

Online
Snagit
Regis-
tration Dia-
log

After installing, the Snagit Registration dialog
appears which includes options to register the soft-
ware online and to sign up for product announce-
ments, customer stories, and free tutorials.

Turns off the dis-
playing the online
registration dialog for
users.
Helps to prevent user-
entered errors when
registering the soft-
ware or duplicating the
registration inform-
ation online.

Image Cap-
ture

Image Capture takes a snapshot of anything on
your screen including a region, window, scrolling
window, or the entire screen.

If you want to disable the
Image Capture Profiles and
controls.

Video Record, trim unwanted sections, and playback
MPEG-4 videos in Snagit.

If users are running
Snagit on a computer
that does not support
video system require-
ments.
To allow an admin-
istrator to control
resources
(CPU/GPU/Band-
width) when deploying
in virtualized envir-
onments.
If runningWindows
Server 2008 orWin-
dows Server 2008 R2
to remove the video
capture and playback
options for users.
Video playback and
decoding is not sup-
ported on this OS.

Printer Cap-
ture

Snagit installs as a printer destination for programs
with printing capability.

When deploying in a server
environment (e.g. Remote
Desktop Services).



Snagit Snagit Deployment Tool Guide

www.techsmith.com -10-

Option Description When Should I Consider
Disabling It?

The Printer Capture Option scans the document in a
program and opens the capture in Snagit Editor.

Note: If you disable printer
capture, make sure to also
disable the Snagit Printer
option on the Install Features
tab of the Deployment Tool.
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Install Features Options

TheOutput Accessories help you to quickly send captures to third party websites and applications for easy
sharing of your images and videos in Snagit. The outputs appear on the Share tab in Snagit Editor.

You can select which output accessories are available to users. If you disable any of the options above, the
output will not appear on the Share tab in Snagit for the end user.

For example, if YouTube is blocked in your organization, youmay want to remove the option to Share to You-
tube in Snagit.

Option Description

Snagit Snagit installs as a printer destination for programs with printing capability.
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Option Description

Printer

The Printer Capture option scans the current document in a program and opens
the capture in Snagit Editor.

Windows
Explorer
Menu Exten-
sion

Allows users to quickly send images to Snagit’s Batch Converter.

My Places
My Places allows users to set up shortcut locations to quickly import, export, or
share your captures to a cloud storage destination such as OneDrive for Busi-
ness.

Snagit
Accessories

The Snagit Accessories appear on the Share tab in Snagit Editor and allow
users to share their captures to popular destinations.

Microsoft
Word Output Allows users to insert an image from Snagit into aMicrosoft Word document.

Microsoft
Excel Out-
put

Allows users to insert an image from Snagit into aMicrosoft Excel workbook.
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Option Description

Microsoft
PowerPoint
Output

Allows users to insert an image from Snagit into aMicrosoft PowerPoint
presentation slide.

Screencast
Output

Allows users to upload an image or video onto Screencast.com for hosting.
Screencast.com provides a URL for quick sharing or an embed code for adding
the capture onto a website or blog.

Camtasia
Studio Out-
put

Allows users to import an image or video from Snagit into Camtasia Studio,
TechSmith’s screen recording and video editing software.

Note: Youmust have Camasia Studio version 7.0 or later installed to share cap-
tures using this output.

YouTube
Output

Allows users to upload a video from Snagit onto YouTube for video hosting.
YouTube provides a URL for quick sharing to your audience or an embed code
for embedding the capture on a website or blog.

Google
Drive Output

Allows users to upload an image or video from Snagit onto Google Drive to host
content so it is accessible from any web browser or mobile device.

Dropbox Out-
put

Allows users to upload an image or video from Snagit to Dropbox to host con-
tent so it is accessible from any web browser or mobile device.

OneNote
2013Output Allows users to insert an image from Snagit into aMicrosoft OneNote notebook.
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TechSmith Fuse Options

TechSmith Fuse is amobile app that allows you to send images and videos from your mobile device directly
to Snagit. You can capture, collaborate, and access your content - wherever you are.

Fuse is available from the App Store, Google Play, or theWindows Store and supported onmobile devices run-
ning the following operating systems:

iOS version 7 and later (phones and tablets)

Android version 4.0 and later

Windows 8.1 and later orWindows RT
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Note: Some security settings and wireless network environments may not allow connectivity to a desktop.
Make sure to validate port 8298 is open to the desktop when working in a virtual environment.

User Data Path Options

You can change or customize the location for storing user data on the User Data Paths screen.

Automatically stored files

Snagit automatically saves all captures into the DataStore folder. The default location for this folder is:
%LOCALAPPDATA%\TechSmith\Snagit\DataStore.

To help prevent users from losing data and to limit users from changing the path, it is recommended to disable
the option in the Deployment Tool to “Allow user to change the automatically stored files location.”

This option for users is located in Snagit Editor, under File > Editor Options > Advanced tab > Automatically
stored files location.

Installed accessories

The Snagit Accessories appear on the Share tab in Snagit Editor and allow users to share their captures to
popular destinations. The default location to store the installed accessories is:
%LOCALAPPDATA%\TechSmith\Snagit\Accessories.

If you select a custom folder to store the installed accessories, consider the following items:
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For roaming profiles, you should use a location that is common and available to all users.

If a user does not have write access to the folder, Snagit disables the ability for users to update or
remove Accessories from the Accessories Manager in Snagit Editor.
For 64-bit environment, It is recommended to use: %ProgramFiles(x86)%\TechSmith\Sn-
agit12\Accessories

Other user settings

User settings such as quick styles, cached thumbnails, additions to the spelling dictionary, TUDI files, etc.
are stored by default in: (%LOCALAPPDATA%\TechSmith\SnagIt).

Add Snagit Accessories Options

Outputs help you to quickly send captures to third party websites and applications for easy sharing of your
images and and videos in Snagit. Snagit offers a number of convenient outputs available on the TechSmith
website: http://www.techsmith.com/snagit-outputs-windows.html.

To includemore outputs in addition to the ones selected on the Install Features screen of the Deployment
Tool:

1. Download the additional outputs to include with deployment from the website: http://www.tech-
smith.com/snagit-outputs-windows.html.

2. On the Add Snagit Accessories screen of the Deployment Tool, click the Add button.

http://www.techsmith.com/snagit-outputs-windows.htm
http://www.techsmith.com/snagit-outputs-windows.html
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3. Browse and select the desired .snagacc file. Control-click to addmultiple files.
4. Click Open.

Snagit Registry File Options

The registry file contains custom settings within the Snagit application such as profiles, appearance settings,
and hotkeys.

Some of these custom settings are located in the following locations:

In the CaptureWindow, select Additional options and help > Preferences.
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In Snagit Editor, select File > Editor Options.

In the CaptureWindow, select View Profiles > Manage Profiles to set up custom profiles for your organ-
ization. Profiles are a set of saved capture settings. Snagit includes several pre-configured profiles to
get you started.

Stamps, Quick Styles, and options in the Quick Access Toolbar are not stored in the registry
file and cannot be deployed tomultiple users.
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To deploy custom Snagit settings tomultiple users:

1. Install Snagit.
2. Set up Snagit with the desired settings and customizations for your organization.
3. Close Snagit.
4. Run Command Prompt as an administrator.
5. Make sure Snagit is not running. To create the Snagit registry file on your desktop, enter the following

into the Command Prompt:

c:\Program Files (x86)\TechSmith\Snagit 12\Snagit32.exe" /e

%HOMEPATH%\Desktop\Snagit.reg

6. In the TechSmith Deployment tool, click the Snagit Registry File tab and select Customize Snagit
registry settings by importing a Snagit.reg file.

7. Click the Browse button to select a Snagit.reg file.
The transform (MST) file generated from the Deployment Tool will use the settings from the registry as the
default settings when installing Snagit.

Uninstall Options



Snagit Snagit Deployment Tool Guide

www.techsmith.com -20-

When uninstalling Snagit, you can choose to keep or delete the user’s Snagit files including unsaved cap-
tures, flags, tags, and capture information. If you plan to reinstall or upgrade Snagit for this user, we recom-
mend keeping these files.

Select one of the following options on the Uninstall Options screen:

Prompt users with this dialog:When uninstalling Snagit, allow the user to select whether to keep or
delete their files.
Keep files:Automatically keep the user’s files when uninstalling Snagit. Users are not prompted with
this dialog.
Delete files:Automatically deletes the user’s files when uninstalling Snagit. Users are not prompted
with this dialog.

Install Display Options

Select one of the following options:

Quiet display: Installs Snagit silently with no setup interface displayed. May be run from a non-admin-
istrator command prompt. It will not return the command prompt until Snagit has finished installing.
Passive display: Installs Snagit from an administrator command prompt. It returns the command
prompt immediately (non-blocking). Theminimal setup is displayed and Snagit notifies the user when
the installation is complete.
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Create Transform File

Click the Create Transform button to generate the following files based on the options selected within the
Deployment Tool:

Transform file (MST)

Batch Processing file (BAT)
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Additional Resources
Enterprise Resources

TechSmith Enterprise Resources website (www.techsmith.com/enterprise-resources.html)

Snagit MSI Installation Guide
View or customize the individual registry settings for Snagit.

Technical Support (support.techsmith.com)
A friendly, knowledgeable voice is just a phone call away.

Toll Free: 1.800.517.3001 (U.S. and Canada only)

Phone: +1.517.381.2300

http://www.techsmith.com/enterprise-resources.html
http://www.techsmith.com/enterprise-resources.html
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